В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Columbos
Columbos
10.04.2021 04:54 •  Информатика

написать программу С++ Создать класс RAILCAR, содержащий следующие поля (члены класса): закрытые — номер вагона; название пункта назначения; категория груза; публичные — методы ввода данных и отображения их на экран. Объявить пять объектов класса, внести данные и показать их.

Показать ответ
Ответ:
ilonka20048
ilonka20048
11.11.2021 18:05

Сообщение по информатике на тему «Информационное общество»

 

    Под информационным обществом, как правило, понимают общество, в котором большинство работающих занято производством, хранением, переработкой и реализацией информации, особенно высшие ее формы – знания.

    Мы живем в век научно-технических открытий, достижений, и, конечно же информационных технологий. Мы используем повседневно компьютеры, пользуемся мировой паутиной –интернет. Из интернета мы черпаем дополнительные знания, раньше для этого приходилось ходить в библиотеку. Мы можем посмотреть, например, мюзикл в Париже, находясь дома в Москве. Мы можем общаться посредством скайпа или социальных сетей с людьми, которые в данный момент далеко. Раньше надо было писать письма и звонить с телеграфа.  Сегодня невозможно представить жизнь без интернета. Странно, как же люди жили до этого?

   А до этого люди жили без высоко – точных технологий. Тысячи людей трудились на благо страны в научных институтах, делали расчеты, чертежи и т.д. Сейчас процесс можно упростить, достаточно заложить программу, и вовсе необязательно держать такой большой штат, все сделают машины. Сейчас практически везде автоматизированное производство. Но вот что странно, как показывает история, без высоко -точных технологий, все было лучше, точнее, прочнее. Самолеты не падали, обувь носилась целыми поколениями, продукты питания были натуральными, без химических добавок. А специалисты были гораздо грамотнее и ответственнее, чем сейчас.

   Но время не стоит на месте, диктует нам свои условия, общество развивается дальше по постиндустриальному пути. Появляются новые технологии, изобретения, современное медицинское оборудование и т.д.  Сегодня общество в целом можно смело отнести к информационному.

 

0,0(0 оценок)
Ответ:
альбинка28
альбинка28
06.02.2020 07:32
// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
begin
  var s:string:='The factors of 12 are 1, 12, 2, 6, 3 and 4';
  s.Where(c->c in ['0'..'9']).Distinct.Println
end.

Результат выполнения программы:
1 2 6 3 4

Если хочется именно СОЗДАТЬ множество, а потом его вывести, то:

// PascalABC.NET 3.1, сборка 1201 от 18.03.2016
begin
  var s: string := 'The factors of 12 are 1, 12, 2, 6, 3 and 4';
  var s1:=s.Where(c -> c in ['0'..'9']).Distinct;
  var c:set of '0'..'9':=[];
  foreach var e in s1 do Include(c,e);
  Writeln(c)
end.

Результат выполнения программы:
{3,2,4,6,1}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота