В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
nasta086
nasta086
03.06.2023 14:59 •  Информатика

Написать программу,составить алгоритм вычисления среднего арифметического значения массива из 15 целых чисел. числа вводить с использованием генератора случайных чисел. итоговая оценка

Показать ответ
Ответ:
yaroslavgolova
yaroslavgolova
01.10.2020 22:45
Var
  i,n:integer;
  s:real;
begin
  Randomize;
  writeln('Исходные числа');
  s:=0;
  for i:=1 to 15 do begin
    n:=random(100)-50;
    write(n:4);
    s:=s+n
    end;
  s:=s/15;
  writeln;
  writeln('Среднее арифметическое равно ',s)
end.

Тестовое решение:

Исходные числа
  -5 -41 -36  44  -2   8 -24  10   0  20  -8  15  14  35  44
Среднее арифметическое равно 4.93333333333333
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота