В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Esenbekmalika30
Esenbekmalika30
24.11.2022 10:05 •  Информатика

Написать программу создания одномерного массива, состоящего из 15 элементов , с датчика случайных чисел​

Показать ответ
Ответ:
95Laura95
95Laura95
24.01.2021 19:08

1

2

3

4

5

6

7

8

9

10

11

12

13

14

15

16

17

18

19

20

21

22

23

24

25

26

27

28

29

30

31

32

33

34

35

36

37

38

a, b : array [1..n] of integer;

i, max, min, p, imax, imin : integer;

begin

randomize;

writeln('исходный массив a[]:');

for i := 1 to n do

begin

a[i] := random(50) - 25;

write(a[i]:8)

end;

writeln;

{формируем и выводим новый}

{сразу осуществляем поиск максимума и минимума}

max := -1000; min := 1000;

writeln('новый массив b[]:');

for i := 1 to n do

begin

b[i] := a[i] * a[i] * a[i];

write(b[i]:8);

if b[i] > max then

begin

imax := i;

max := b[i]

end;

if b[i] < min then

begin

imin := i;

min := b[i]

end

end;

writeln;

{считаем произведение и выводим результаты}

p := max * min;

writeln('максимальный элемент нового массива - b[', imax, '] = ', max);

writeln('минимальный элемент нового массива - b[', imin, '] = ', min);

writeln('их произведение = ', p);

readln

end.

0,0(0 оценок)
Ответ:
эмили40
эмили40
24.01.2021 19:08

ответ я сам не знаю но я думаю что...

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота