В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
PISOS228XYI
PISOS228XYI
20.03.2022 10:45 •  Информатика

Написать программу суммирующую числа до тех пор пока не будет введён "0".
Входные данные:
1 2 3 0
Выходные данные:
6
2. Написать программу поиска НОД (Наибольший Общий Делитель) двух чисел.
Входные данные:
170 42
Выходные данные:
2

Показать ответ
Ответ:
marimitul
marimitul
14.10.2020 13:01

1)

program g;

var

a, b, c, d:integer;

begin

Readln(a, b, c, d) ;

begin

if a = 0 then

Writeln('0') end ;

begin

if b = 0 then

Writeln(a) end ;

begin

if c = 0 then

Writeln(a + b) end ;

begin

if d = 0 then

Writeln(a + b + c) end ;

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота