В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Anton222666222
Anton222666222
31.01.2022 13:56 •  Информатика

Написать программу суммирующую n элементов начиная с номера x по номер y из 10 элементов массива введенных случайным образом (pascal)

Показать ответ
Ответ:
mordvichev92
mordvichev92
11.08.2020 21:18

===== PascalABC.NET =====

begin

 var a := ArrRandom(10, -99, 99);

 a.Println;

 var (x, y) := ReadInteger2('С какого по какой элементы суммировать?');

 a?[x - 1:y].Sum.Println

end.


Написать программу суммирующую n элементов начиная с номера x по номер y из 10 элементов массива вве
0,0(0 оценок)
Ответ:
andrew211
andrew211
20.01.2024 16:30
Конечно, я могу вам помочь. Вот программа на языке Pascal для суммирования n элементов массива, начиная с номера x по номер y.

Программа:
```
program SumArrayElements;
var
arr: array[1..10] of Integer; // создаем массив из 10 элементов
n, x, y, i, sum: Integer; // объявляем переменные

begin
Randomize; // инициализируем генератор случайных чисел

// заполняем массив случайными числами
for i := 1 to 10 do
begin
arr[i] := Random(100); // генерируем случайное число от 0 до 99 и записываем в массив
end;

// выводим все элементы массива для проверки
for i := 1 to 10 do
begin
Write(arr[i], ' ');
end;
Writeln; // переходим на новую строку

// просим пользователя ввести значения n, x и y
Write('Введите количество элементов для суммирования (n): ');
Readln(n);
Write('Введите начальный номер элемента (x): ');
Readln(x);
Write('Введите конечный номер элемента (y): ');
Readln(y);

// проверяем, что введенные значения x и y находятся в допустимом диапазоне
if (x < 1) or (x > 10) or (y < 1) or (y > 10) or (x > y) then
begin
Writeln('Ошибка: недопустимые значения x и y');
Exit; // выходим из программы
end;

// суммируем элементы массива от номера x до номера y
sum := 0;
for i := x to x + n - 1 do
begin
sum := sum + arr[i];
end;

// выводим сумму элементов на экран
Writeln('Сумма ', n, ' элементов массива от номера ', x, ' до номера ', y, ' равна ', sum);
end.
```

Объяснение программы:
1. На первых трех строчках мы создаем массив `arr` из 10 целочисленных элементов, и объявляем переменные `n`, `x`, `y`, `i` и `sum`.
2. С помощью цикла `for` и генератора случайных чисел (`Random`) мы заполняем массив `arr` случайными числами от 0 до 99.
3. Следующий цикл выводит все элементы массива `arr`, чтобы вы могли убедиться, что числа действительно случайные.
4. Затем мы просим вас ввести количество элементов для суммирования (`n`), начальный номер элемента (`x`) и конечный номер элемента (`y`).
5. Проверяем, что введенные значения `x` и `y` находятся в допустимом диапазоне (от 1 до 10) и что `x` не больше `y`.
6. Далее мы суммируем элементы массива от номера `x` до `y` с помощью цикла `for`.
7. Наконец, выводим на экран сумму элементов массива от номера `x` до `y`.

Надеюсь, это поможет вам разобраться с задачей. Если у вас возникнут вопросы или нужна будет дополнительная помощь, не стесняйтесь задавать.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота