В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу (турбо паскаль)

создать текстовый файл, содержащий слова, записанные в столбик. добавить в этот же файл слова, зашифровав их сдвигом на 2 символа (а -> в, я -> б).

Показать ответ
Ответ:
id95874775
id95874775
07.01.2024 18:13
Хорошо, чтобы написать такую программу на Turbo Pascal, нам понадобится использовать файловые операции и работу с символами. Вот пошаговое решение:

1. Начнем с создания текстового файла и записи слов в столбик. Для этого используем следующий код:

```
program EncryptWords;
var
wordsFile: Text;
word: string;

begin
// Открываем файл для записи слов
Assign(wordsFile, 'words.txt');
Rewrite(wordsFile);

// Вводим слова с клавиатуры и записываем их в файл
writeln('Введите слова (пустая строка для окончания):');
repeat
readln(word);
writeln(wordsFile, word);
until word = '';

// Закрываем и сохраняем файл
Close(wordsFile);
end.
```

2. Теперь давайте добавим шифрование слов. Мы будем считывать слова из файла, изменять каждую букву на две позиции вперед, а затем записывать зашифрованные слова обратно в файл. Вот измененный код:

```
program EncryptWords;
var
wordsFile: Text;
encryptedFile: Text;
word: string;
i: integer;

begin
// Открываем файл с исходными словами
Assign(wordsFile, 'words.txt');
Reset(wordsFile);

// Открываем новый файл для записи зашифрованных слов
Assign(encryptedFile, 'encrypted_words.txt');
Rewrite(encryptedFile);

// Считываем слова из файла и шифруем их
while not eof(wordsFile) do
begin
readln(wordsFile, word);

// Шифруем каждую букву в слове
for i := 1 to length(word) do
begin
// Сдвигаем символ на две позиции вперед
word[i] := chr(ord(word[i]) + 2);

// Если символ выходит за пределы алфавита, возвращаем его назад
if ord(word[i]) > ord('я') then
word[i] := chr(ord(word[i]) - 32); // Вернуть в алфавите прописные буквы

if ord(word[i]) > ord('Z') then
word[i] := chr(ord(word[i]) - 26); // Вернуть в алфавите заглавные буквы
end;

// Записываем зашифрованное слово в новый файл
writeln(encryptedFile, word);
end;

// Закрываем и сохраняем файлы
Close(wordsFile);
Close(encryptedFile);
end.
```

3. После запуска программы вы увидите, что в папке с программой появился файл `encrypted_words.txt`, содержащий нешифрованные слова, зашифрованные сдвигом на два символа вперед.

Вот и все! Программа создаст файл `words.txt`, где вы можете вводить слова, записанные в столбик. Затем она создаст и заполнит файл `encrypted_words.txt`, где эти слова будут зашифрованы. Она шифрует каждую букву, сдвигая ее на две позиции вперед и обрабатывая символы, выходящие за пределы алфавита.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота