В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
dianaism38
dianaism38
27.03.2023 20:25 •  Информатика

Написать программу turpo pascal что ! вывести на экран 6 раз свое имя. составить блок-схему и написать программу вычисления суммы чисел от 6 до 10. написать программу вычисления n! (факториал числа n), где n- целое
неотрицательное число. определение факториала: 0! =1, 1! =1, 2! =1*2, 3! =1*2*3, ……,n! =1*2*3*…*(n-1)*n. другими словами n! - это произведение n натуральных чисел.

Показать ответ
Ответ:
nastusya1709
nastusya1709
24.05.2020 03:28

1. вывести на экран 6 раз своё имя

program imya;

const n=6;

var i:integer;

begin

for i:=1 to n do

writeln('ваше имя');

end.

Пояснения: делала с цикла (можно было написать и шесть раз writeln, но так удобнее). Переменную n ввела для быстрого изменения значений (если нужно будет написать имя не 6, а, к примеру, 8 раз, нужно было заменить только вначале). Ещё хочу отметить, что имя вводится по-английски и нельзя терять апострофы ( ' ).

2. program sum;

var sum:integer;

m:array[1..4] of integer;

i:integer;

begin

m[1]:=6

for i:=2 to 4 do begin

m[i]:=m[i-1]+1;

end;

sum:=m[1];

for i:=2 to 4 do begin

sum:=sum+m[i];

end;

writeln(sum);

end.

Пояснения: можно было делать и по-другому, но так тоже верно. Тут использовалось два цикла и массив. А блок-схему сами сделайте)))

3. program n!;

var n:real;

c:integer;

m:array[1..n] of integer;

begin

readln(n)

m[1]:=1;

for i:=2 to n do begin

m[i]:=m[i-1]+1;

end;

c:=m[1]

for i:=1 to n do begin

c:=c*m[i];

end;

writeln('n!',c);

end.

Если что не понятно, пишите, объясню

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота