В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
den53499
den53499
06.06.2020 16:01 •  Информатика

Написать программу условия приема детей, в секцию баскетбола возраст которых не менее 9 лет и рост более 150 см.
Паскаль

Показать ответ
Ответ:
Artem1143
Artem1143
29.02.2020 01:00
//PascalABC.NET (версия 3.1, сборка 1210 от 29.03.2016)
const
  m = 10;

var
  t: array[1..m] of integer;
  i, n, nm, sm: integer;

begin
  //Заполняем массив сл.числами и подсчитываем
  //количество элементов и среднее арифметическое
  //согласно условию задачи
  for i := 1 to m do
  begin
    t[i] := random(-20, 20);write(t[i]:4);
    if (i > 1) and (i <= m) then
      if t[i] > t[i - 1] then n := n + 1
      else if t[i] < t[i - 1] then begin
        sm := sm + t[i];nm := nm + 1;
      end;
  end;
  writeln;
  writeln('число элементов больших предыдущего = ', n);
  writeln('ср. арифметическое элементов меньших предыдущего = ', sm / nm);  
 
end.

Тестовое решение:
    6  13  19   8 -19 -11 -20 -15 -19 -13
число элементов, больших предыдущего = 5
среднее арифметическое элементов, меньших предыдущего = -12.5
0,0(0 оценок)
Ответ:
skseeen15
skseeen15
06.10.2021 11:36
Var x1,y1,x2,y2,v1,v2:real;
begin
  writeln("введите количество метров пробегания жирафа");
  read(y1);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x1);
  writeln("введите количество метров пробегания зайца");
  read(y2);
  writeln("введите, за сколько секунд он должен пробежать");
  read(x2);
  v1:=y1/x1;
  v2:=y2/x2;
  if v1>v2 then 
  begin
     writeln("жираф чемпион");
  end
  else if v1<v2 then 
  begin
     writeln("заяц чемпион");
  end
  else
  begin
    writeln("победила дружба);
  end;
end;
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота