В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kriss6745
kriss6745
01.10.2020 20:08 •  Информатика

Написать программу в c# введите количество натуральных делителей включая 1 и само число

Показать ответ
Ответ:
6a6yle4ka
6a6yle4ka
09.10.2020 22:55

using System;

namespace DividersAmount

{

   class Program

   {

       static void Main(string[] args)

       {

           int n = int.Parse(Console.ReadLine());

           int amount = 0;

           for (int i = 1; i <= n; i++)

           {

               if (n % i == 0) amount++;

           }

           Console.WriteLine(amount);

           Console.ReadKey();

       }

   }

}

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота