Написать программу, в которой вводится последовательность целых чисел, оканчивающаяся нулем (т.е. признак окончания ввода чисел в последовательности – ввод нуля). программа должна посчитать и вывести количество отрицательных чисел в этой последовательности. программу реализовать двумя при цикла с пред- и пост- условием.
number: integer;
k: integer;
begin
repeat
write('number = ');
readln(number);
if number < 0 then k := k + 1;
until number = 0;
writeln('Кол-во отрицательных = ', k);
end.