В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
kymbatbadagulovа
kymbatbadagulovа
22.04.2022 21:07 •  Информатика

написать программу в кумире:
Заполните таблицу размерности N неповторяющимися целыми случайными числами из интервала от 1 до N. Вывести полученную таблицу на экран. Определите среднее арифметическое элементов полученной таблицы.
Пример выполнения:
алг среднее_арифметическое_элементов_таблицы
нач
цел N
вещ rez
лог error
вывод "Кол-во случайных чисел=>>"
ввод N
error:=(N<1)
если error
то вывод "Таблицу создать невозможно"
выход
все
цел таб A[1:N]
InputTable(N,A)
вывод "Заполненная таблица:",нс
OutputTable(N,A)
rez:=Average(N,A)
вывод "Среднее арифметическое элементов таблицы:",rez
кон
алг вещ Average(цел size, цел таб Table[1:size]) нач
цел S, i
S:=0
нц для i от 1 до size
S:=S+Table[i]
кц
знач:=S/size
кон
алг InputTable(арг цел size, рез цел таб Table[1:size])
нач
цел i
нц для i от 1 до size
Table[i]:= irand(1,size)
кц
кон
алг OutputTable(цел size, цел таб Table[1:size])
нач
цел i
лог error
error:=(size<1)
если error
то вывод "Таблица не содержит элементов"
выход
все
нц для i от 1 до size
вывод i,"-й : ", Table[i]
если i=size
то вывод "."
иначе вывод "; "
все
вывод нс
кц
вывод нс
кон

Показать ответ
Ответ:
Ученица134567
Ученица134567
07.06.2020 10:04
#include <iostream>
using namespace std;
 
int main()
{
    int i = 0;
    cin >> i;
    switch(i) {
        case(1) : { cout << "Вторник"; break; }
        case(2) : { cout << "Среда"; break; }
        case(3) : { cout << "Четверг"; break; }
        case(4) : { cout << "Пятница"; break; }
        case(5) : { cout << "Суббота"; break; }
        case(6) : { cout << "Воскресенье"; break; }
        case(7) : { cout << "Понедельник"; break; }
    }
    return 0;
}
0,0(0 оценок)
Ответ:
alesyamorozova
alesyamorozova
09.04.2021 15:57
Программирование многие путают с кодированием, что совершенно неверно. Программирование - это процесс написания программы, который начинается от постановки задачи, а кодирование - это запись уже сконструированного алгоритма в виде программы на языке, понятном исполнителю этой программы.

Заданный вопрос - отличная иллюстрация к написанному выше. Алгоритма нет, поскольку, что автор вопроса не понимает о чем идет речь, но зато он спрашивает, как выполнить кодирование на язык Паскаль. Вполне понятно, что автор самостоятельно этого сделать не может.

Вернемся к заданию. Насколько его можно попытаться понять, речь идет о кусочной функции.
\displaystyle S= \left\{\begin{matrix}&#10;x^2, & x\ \textless \ 0\\ 5, & x=0\\ x-12, & x\ \textgreater \ 0 &#10;\end{matrix}\right.

Кусочная функция содержит условия, определяющие её части на различных интервалах. Поскольку в условиях есть операции сравнения, в Паскале понадобится условный оператор if - then - else, причем не один.

// PascalABC.NET 3.3, сборка 1547 от 07.10.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var x:=ReadReal('x=');
  var s:real;
  if x<0 then s:=x*x else
    if x=0 then s:=5
    else s:=x-12;
  Writeln(s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота