В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Panda2004s
Panda2004s
21.09.2020 09:14 •  Информатика

Написать программу в pascal.дан набор слов, разделенных точкой с запятой (; ). набор заканчивается двоеточием (: ). определить, сколько в нем слов, заканчивающихся буквой а.

Показать ответ
Ответ:
Vik1767
Vik1767
01.10.2020 22:41
var
  str: string;
  i  : byte;

begin
  readln(str);
  str := str.Replace(':', '');
  foreach c: string in str.Split(';') do
    if (c[c.Length] in ['a', 'а']) then //не уточнено, какого алфавита "а"
      i += 1;
  writeln(i);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота