В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Scucorif
Scucorif
17.02.2022 06:03 •  Информатика

Написать программу в pascal даны число a> 0, числа x1, необходимо вводить числа x1, , пока сумма модулей введенных чисел будет меньше a. определить число введенных чисел. p.s в поисковике искал, нашел 2 какие-то странные программы, они мне не подходят

Показать ответ
Ответ:
Rororor11111
Rororor11111
11.08.2020 07:48
Var
  a,x,k,s:integer;
begin
  Write('a=');
  Readln(a);
  k:=0;
  s:=0;
  while s<a do
  begin
    Read(x);
    s:=s+abs(x);
    Inc(k)
  end;
  Writeln('Введено чисел ',k)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота