В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
valeriybalybin
valeriybalybin
03.06.2022 00:32 •  Информатика

Написать программу в pascalabc.net удалить из строчки s символы + - * а потом заменить все символы на символы следующие по алфавиту.

Показать ответ
Ответ:
бернер
бернер
07.10.2020 11:04
// PascalABC.NET 3.3, сборка 1590 от 03.12.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('Введите строку:');
  s:=s.RegexReplace('[\+\-\*]',''); // удалили
  s:=s.Select(c->Chr(Ord(c)+1)).JoinIntoString(''); // заменили
  Writeln(s)
end.

Пример:
Введите строку: Мой пример: 23+18.4*(3.1-0.15)=52.7 Is it true?
Нпк!рсйнжс;!3429/5)4/21/26*>63/[email protected]
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота