В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Xela936
Xela936
07.01.2022 19:31 •  Информатика

Написать программу в паскаль. дан массив целых чисел, состоящий из 20 элементов. заполнить его датчиком случайных чисел. заменить максимальный элемент на противоположный по знаку.

Показать ответ
Ответ:
myisipov1erg
myisipov1erg
05.07.2020 12:25
Program chik;
const n=20;
var a:array[1..20]of integer;
i,l,max:integer;
begin
randomize;
for i:=1 to n do
a[i]:=random(100)-50;
max:=a[1];
for i:=2 to n do
if(a[i]>max)then max:=a[i];
for i:=1 to n do
begin
if(a[i]=max)then a[i]:=-max;
write(a[i],' ');
end;
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота