В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
МиссисX2
МиссисX2
09.09.2021 09:43 •  Информатика

Написать программу в паскаль для расчёта необходимого количества краски для покраски гаража. гараж имеет форму параллелепипеда. красят все наружные поверхности (их 5). программа должна спрашивать длину, ширину, высоту и выводить на экран количество краски в литрах. расход краски: 0.2 литра на кв. метр.

Показать ответ
Ответ:
Ermolenkoo
Ermolenkoo
07.10.2020 14:19

program raf105;

var

 a,b,c,paint: real;

begin

 write('Длина: ');

 readln(a);

 write('Ширина: ');

 readln(b);

 write('Высота: ');

 readln(c);

 paint:= (a*c*2 + b*c*2 + a*b) * 0.2;

 writeln('Требуется ',paint,' л. краски');

end.

PascalABC
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота