В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Maksgeem
Maksgeem
19.05.2023 15:36 •  Информатика

Написать программу в паскаль. задано количество строк и столбцов матрицы и действительные значения ее элементов. сформировать и вывести транспонированную матрицу.

Показать ответ
Ответ:
elyakhina1976
elyakhina1976
03.10.2020 02:25
Const
e=10000;
var
a:array[1..e,1..e] of real;
i,j,n,m:integer;
k:real;
begin
readln(n,m);
for i:=1 to n do
  for j:=1 to m do
  read(a[i,j]);
for i:=1 to n do 
for j:=i+1 to m do   
begin     
k:=a[i,j];     
a[i,j]:=a[j,i];     
a[j,i]:=k;   
end;   
for i:=1 to m do   
begin     
for j:=1 to n do 
write(a[i,j],' '); 
writeln; 
end; 
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота