В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
margusqw
margusqw
02.04.2020 00:59 •  Информатика

Написать программу в паскале: 1.удвоить заданное число, если оно положительное, утроить его, если оно отрицательно, и увеличит его на 1, если оно равно нулю.

Показать ответ
Ответ:
svetokot2005
svetokot2005
05.07.2020 08:53
Var a:real;
begin
readln(a);
if a>0 then a:=a*2;
if a<0 then a:=a*3;
if a=0 then a:=a+1;
writeln(a)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота