В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу в паскале: 1) вводятся 10 целых чисел. подсчитать количество четных среди них 2) вывести на экран все трехзначные числа, сумма цифр которых равна n (значение n вводится с клавиатуры). 3) вывести на экран все трехзначные числа-палиндромы, т.е. такие числа, которые одинаково читаются как слева направо, так и справа налево.

Показать ответ
Ответ:
Ljshegsyweee
Ljshegsyweee
10.06.2020 16:17

var

  i, c : byte;

  t : integer;

begin

  c := 0;

  for i := 1 to 10 do

  begin

    read (t);

    if t mod 2 = 0 then inc (c);

  end;

  writeln (c);

end.

 

var

  n, i : integer;

begin

  read (n);

  for i := 100 to 999 do

    if i mod 10 + i div 10 mod 10 + i div 100 = n then writeln (i);

end.

 

var

  i : integer;

begin

  for i := 100 to 999 do

    if i mod 10 = i div 100 then writeln (i);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота