В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Alinka24Alinka
Alinka24Alinka
26.11.2021 16:28 •  Информатика

Написать программу в паскале через цикл: гречу, массой х г, рассыпают по пакетам: по а г в каждый. пакетов может быть неограниченное количество. сколько гречи будет в последнем заполненном пакете? , .

Показать ответ
Ответ:
MARZHIVANKINA
MARZHIVANKINA
01.03.2023 15:45
Const
    N = 10;

var
    A: array[1..N] of integer;

function Fun: integer;
var
    i, M: integer;
begin
    writeln('Введите число M=');
    readln(M);
    for i := 1 to N do
        if A[i] = M then Fun := i;
end;

procedure CreateMassive;
var
    i: integer;
begin
    for i := 1 to N do
    begin
        A[i] := Random(199) - 100;
        write(A[i],' ');
    end;
    Writeln;
end;

begin
    CreateMassive;
    Writeln(Fun);
end.

вот вариант исправления который работает, хотя конечно не факт что он работает как там кто-то задумывал)))
не понятно было назначение функции Fun потому она делает поиск номера элемента равного М
а вообще глобальные переменные это зло. Так что проектирование тут в корне не верно
0,0(0 оценок)
Ответ:
aguscov
aguscov
29.04.2023 15:51

Резервное копирование в облако: преимущества...рассказываем о преимуществах и недостатках резервного копирования в облако. ... Резервное копирование в облако: преимущества и недостатки. 15 января 2019. Безопасность, сохранность и оперативность доступа к данным очень важны для бизнеса. ... Часто предприятию требуется в технической экспертизе, чтобы использовать и правильно настроить-решения для бизнес-критичной информации. Локальное копирование обходится недёшево, тем не менее, такой не всегда эффективен. А между тем, различные аварии, отказы оборудования и катастрофы могут происходить внезапно ну как то так

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота