В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
alisheralisher2
alisheralisher2
23.09.2022 06:47 •  Информатика

Написать программу в паскале дано трехзначное число х найти сумму его цифр, среднее арифметическое и записать число в обратном порядке.

Показать ответ
Ответ:
Saida6666
Saida6666
20.07.2020 15:12

program n_1;

var m,n,n1,n2,n3,n4:integer;

begin

 writeln('Введите трехзначное натуральное число: ');

 readln(n);

 n1:=n mod 10;

 n2:=(n mod 100) div 10;

 n3:=n div 100;

 m:=n1+n2+n3;

 writeln('Сумма цифр: ',m);

 writeln('Среднее арифметическое: ',m/3:0:5);

 m:=100*n1+10*n2+n3;

 writeln('В обратном порядке: ',m)

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота