В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу в паскале,использующую функцию,которая возвращает значение выражения. y=a^2-5b^3+корень из (4a+b)

Показать ответ
Ответ:
serjksu
serjksu
25.05.2020 22:28

var

  a, b: real;  //Числа а и b

function CalculateY(a, b: real): real;  //Функция вычисления y

begin

  CalculateY:= sqr(a) - 5 * (sqr(b) * b) + sqrt(4 * a + b);

end;

begin

  writeln('Введите числа а и b');

  readln(a, b);  //Вводим числа а и b

  writeln(CalculateY(a, b));  //Печатаем возвращаемое функцией значение 

end.

 

0,0(0 оценок)
Ответ:
nik13243546576879
nik13243546576879
25.05.2020 22:28

var a,b:real;

begin

readln(a,b);

writeln(sqr(a)-5*sqr(b)*b+sqrt(4*a+b));

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота