В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Bigdaddypro100
Bigdaddypro100
25.10.2020 22:26 •  Информатика

Написать программу в паскале которая сначала должна обеспечить ввод 5 чисел в одномерный массив затем вычислить количество четных и вывести сумму четных на экран a[1]=6 a[2]=5 a[3] a[4]=3 a[5]=2 количество четных чисел =3 cумма четных чисел=12.

Показать ответ
Ответ:
zalalova05
zalalova05
09.10.2020 11:18

//PascalABC.NET v3.3 1633


var arr: array [1..5] of integer;

begin

 for var i:=1 to 5 do

   arr[i]:=readinteger('Введите '+i+' элемент массива: ');

 

 var sum:=0;

 var number:=0;

 for var i:=1 to 5 do

   if arr[i] mod 2 = 0 then

   begin

     sum += arr[i];

     number += 1;

   end;

 

 writeln('Количество четных чисел = '+number);

 writeln('Сумма четных чисел = '+sum);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота