Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Danaaad
30.11.2022 22:54 •
Информатика
Написать программу в паскале: определить, четное число или нечетное, если четное - разделить на два и вывести результат на экран
Показать ответ
Ответ:
Стешулький361953
08.10.2020 13:28
Var a : integer;
begin
writeln('Введите число');
read(a);
if (a mod 2 = 0) then a:= a div 2 else a:=a;
writeln(a);
end.
0,0
(0 оценок)
Популярные вопросы: Информатика
Redimer
06.10.2022 03:49
Задан массив состоящий из 10 элементов, определить произведение всех нечётных элементов в массиве...
Polk1512
25.07.2021 01:48
Даны два числа. определить какой число имеет больше делителей. в паскале цикл...
Kamaria086
17.08.2020 05:18
В некоторой знаковой системе алфавит состоит из 64 знаков. Каков информационный вес одного символа? ответ выразите в битах....
21VR
16.02.2022 04:10
как написать с чертежника имя Даша в кумире! дам за это ...
Larkys2017
10.02.2023 14:14
Распределите социальные технологии по соответствующим группам в таблицу: По характеру воздействия По масштабности - Формирующие - Локальные - Стимулирующие - Разрушающие...
linik2
11.10.2022 08:19
Сколько единиц в двоичной записи десятичного числа 64^30 + 128^5 - 256^3 ?...
алла7781
08.07.2020 13:05
В редакторе на раны все цифры от 1 до 9. Нужно выполнить следующие действия: 1. Влево, влево, влево, влево. 2. Bs 3. Del 4. Ctrl+Z Что будет в окне редактора после каждого...
Egor190606
20.07.2022 23:31
1. Значения переменных a и b равны a = 4 и b = 6. Определите, сколько раз выполнится цикл, и чему будут равны значения этих переменных после его завершения: а) while a b:...
Ekaterina090909
25.08.2021 23:10
Яка найменша частина середовища Scratch використовується для створення скриптів? A. Алгоритм В. Дія С. Блок D. Спрайт...
mkalashnik1983
21.11.2022 14:47
Какие противоречия европейские государства к первой мировой войне?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
begin
writeln('Введите число');
read(a);
if (a mod 2 = 0) then a:= a div 2 else a:=a;
writeln(a);
end.