В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
asem052
asem052
29.01.2020 19:42 •  Информатика

написать программу в паскале От дома семьи Ивановых до дачи – k километров. За время поездки на дачу (туда и обратно) Ивановы тратят v литров бензина. Стоимость одного литра – r рублей. Какую сумму нужно потратить на бензин перед поездкой в соседний город, расстояние до которого – L км.?
k, v, r L вводятся пользователем с клавиатуры
(ответ можно в виде текста скопировать из самого паскаля) ​

Показать ответ
Ответ:
ауе60
ауе60
14.09.2020 20:23

pascal

Объяснение:

var

 k, v, r, L : real;

begin

 Write('Введите расстояние до дачи k: ');

 ReadLn(k);

 Write('Расход в литрах v: ');

 ReadLn(v);

 Write('Введите стоимость бензина за литр r: ');

 ReadLn(r);

 WriteLn('*** Расход равен ', v/(2*k):2, ' л/км ***');

 Write('Введите расстояние до города L: ');

 ReadLn(L);

 WriteLn('Для поездки в город потребуется заправить ', (v*L)/k:2, ' литров бензина стоимостью ', (v*L)/k*r:2, ' руб.');

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота