Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
Elluy
17.04.2021 07:31 •
Информатика
Написать программу в паскале: подсчитать количество элементов массива целых чисел,меньших 0. и блок схему,
Показать ответ
Ответ:
sasha11751
07.10.2020 03:16
// PascalABC.NET 3.3, сборка 1555 от 21.10.2017
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln('Элементов, меньших нуля: ',a.Count(x->x<0))
end.
Пример
n= 13
23 -47 39 19 37 -34 -47 -15 -15 -2 -41 6 20
Элементов, меньших нуля: 7
0,0
(0 оценок)
Популярные вопросы: Информатика
dsanavskiy77
08.07.2022 04:09
Вфайле f заменить все нулевые компоненты значением суммы первой и последней компонент файла; все отрицательные компоненты уменьшить на значение суммы, а также найти среднее...
Nanaw45
25.02.2021 23:40
Для какого из чисел ложно высказывание: не (число 50) или (число чётное)? 1) 123 2) 56 3) 9 4) 8...
katemcgrat
25.02.2021 23:40
Составьте программу которая осуществляет ввод в массив с клавиатуры 10 элементов и отрицательные числа возводят в квадрат, а из неотрицательных извлекают квадратный корень...
bbbbbbbbbb2
07.08.2020 10:29
3D моделинин кандай програмасы кенен танымал ...
qqqlw0
02.03.2021 22:19
Данно натуральное число определить, каким по счету числом фибоначчи оно является. если не является, выведите -1. на питоне....
eva444786
24.07.2020 05:07
Решите ! желательно подробно. 1. исполнитель чертёжник перемещается на координатной плоскости, оставляя след в виде линии. чертёжник может выполнять команду сместиться...
Юриякамория
24.08.2020 12:18
Какие форматирования текста существуют ?...
lizabezludnaya
24.08.2020 12:18
Разложите на простые множители числа 168 756...
anfisachupina85
24.08.2020 12:18
Длина прямоугольника равна 23 см длина на 8 см больше ширины чему равен периметр этого прямоугольника...
TheNekyTyan
24.08.2020 12:18
Две семьи купили 9кг черешни по одинаковой цене. одна семья заплатила за покупку 900р а другая-720р.сколько кг купила каждая семья?...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
// Внимание! Если программа не работает, обновите версию!
begin
var a:=ArrRandom(ReadInteger('n='),-50,50); a.Println;
Writeln('Элементов, меньших нуля: ',a.Count(x->x<0))
end.
Пример
n= 13
23 -47 39 19 37 -34 -47 -15 -15 -2 -41 6 20
Элементов, меньших нуля: 7