В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
lanamalinena
lanamalinena
11.02.2021 17:26 •  Информатика

Написать программу в паскале
С клавиатуры вводятся два угла треугольника А, В. Программа выводит, будет ли
он равнобедренным. (Подсказка: не забудьте учесть третий угол).
Предусмотреть в программе, что пользователь может ввести отрицательное число
или число >= 180 или сумма введенных углов >=180, в этом случае должно выдаваться
сообщение об ошибке.
Например: вводим 60 и 20, программа выводит «неравнобедренный треугольник»
вводим 60 и 60, программа выводит «равнобедренный треугольник»
вводим 40 и 100, программа выводит «равнобедренный треугольник»
вводим 200 и 50, программа выводит «Ошибка ввода»

Показать ответ
Ответ:
Варвара75639
Варвара75639
12.07.2020 13:02

Если m ≥ n, то m - n ≥ 0, иначе m - n < 0

Если m и n – целые числа и хранятся в переменных типа int, то результат вычисления разности тоже будет целочисленным.

Целое число со знаком в памяти компьютера представлено в виде 4 Байт, первый бит этого набора выделен для хранения знака. Если этот бит равен 0, то число положительное, если 1 – отрицательное.

Зная это, можно написать программу, которая будет выводить 1, если m ≥ n и любое другое число в противном случае. Для этого достаточно воспользоваться побитовыми операциями. В частности, операторами побитового сдвига и побитового И.

#include <iostream>int main() {    int m, n;    std::cin >> m >> n;    std::cout << ((m - n) >> (sizeof(int) - 1)) + 1; // Разбор ниже    return 0;}

Разберем последнюю строчку. В переменной q хранится разность чисел m и n. Нас интересует первый бит этого числа, так как он хранит информацию о том, положительное число или отрицательное. Для этого нам необходимо с побитового сдвига вправо (>>) сдвинуть все биты числа, хранимого в целочисленной переменной q, кроме самого первого бита. Получить количество бит мы можем, воспользовавшись встроенной функцией sizeof(), от полученного значения достаточно отнять единицу.

Как уже упоминалось ранее, нас интересует положительное число в q, а выражение q >> (sizeof(q) - 1) в этом случае вернёт 0. Для того, чтобы результирующее значение было верным необходимо прибавить к результату выражения 1. Таким образом, условие "Если m≥n, то требуется вывести 1, в противном случае — любое другое число." выполняется.

Стоит отметить, что прибавление единицы к выражению – не единственный вариант. Также можно воспользоваться приведением типов. Например, "std::cout << (int)(!(q >> (sizeof(q) - 1)));" выведет тот же результат.

0,0(0 оценок)
Ответ:
VasyaRaglinskiy66
VasyaRaglinskiy66
27.07.2020 17:56

Программа:

{Free Pascal Compiler version 3.0.4+dfsg-23 [2019/11/25] for x86_64}

{Copyright (c) 1993-2017 by Florian Klaempfl and others}

{Target OS: Linux for x86-64}

program test;

const

 start = -100;

 finish = 50;

 count = 100;

var

 X : array of integer; {массив}

 i : integer; {Счётчик цикла}

 S : integer; {Сумма положительных}

begin

Randomize;

SetLength(X, count+1);

{Генерация массива из 100 элементов от -50 до 50}

for i := 1 to count do

 X[i] := Round( Random * start) + finish;

{Вывод сгенерированного массива на экран}

for i := 1 to count do

 write(X[i]:4);

writeln; writeln;

{Подсчёт положительных элементов}

S := 0;

for i := 1 to count do

 if (x[i] > 0) then

  S := S + x[i];

 

writeln('Сумма положительных S = ', S);

end.


Найти сумму тех элементов массива, которые имеют положительные значения(для Паскаль)​
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота