В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Alika19891
Alika19891
24.02.2023 12:13 •  Информатика

Написать программу в python, которая удаляет все слова в файле, которые содержат в себе цифры.

Показать ответ
Ответ:
belya84
belya84
21.02.2021 15:52
// PascalABC.NET 3.2, сборка 1362 от 14.12.2016
// Внимание! Если программа не работает, обновите версию!

function MatrCreate(m,n:integer):array[,] of integer;
begin
  Writeln('*** Исходный массив A[',m,',',n,'] ***');
  Result:=MatrRandom(m,n,-50,50);
  Result.Println(4);
  Writeln(4*n*'-');
end;

procedure Matr2File(a:array[,] of integer; fn:string);
begin
  var f:file of integer;
  ReWrite(f,fn);
  foreach var r in a.Rows do
    foreach var x in r do Write(f,x);
  f.Close
end;

begin
  var m:=ReadlnInteger('Количество строк в массиве:');
  var n:=ReadlnInteger('Количество столбцов в массиве:');
  var a:=MatrCreate(m,n);
  var s:=ReadlnString('Имя файла:');
  Matr2File(a,s);
  Writeln('Работа завершена')
end.

Пример
Количество строк в массиве: 6
Количество столбцов в массиве: 9
*** Исходный массив A[6,9] ***
  -8  47 -37   8  23  47 -18   5  18
  13 -29   9 -12 -44 -27 -21 -20  11
  17 -18  18  30  14 -42 -34  16  49
  -4 -25  47 -28 -25 -20  39  44 -46
  18 -45  39  12   3  24  27  16 -23
  27  48  30  33 -38 -30  34  35 -50

Имя файла: MyFile.bin
Работа завершена
0,0(0 оценок)
Ответ:
marta62
marta62
28.06.2020 21:35
Var
f: array[1..10] of integer;
i,suma,sumb:integer;
begin
randomize;
for i:=1 to 10 do
begin f[i]:=random(10)+10;
write(f[i],' ');
end;
suma:=0;
sumb:=0;
for i:= 1 to 10 do
if f[i] mod 2 = 0 then
suma:=suma+f[i];
else
sumb:sumb+f[i];
writeln('Сумма четных: ',suma);
writeln('Сумма нечетных: ',sumb);
end.

var
f: array[1..8] of integer;
i,k,sumb:integer;
begin
randomize;
for i:=1 to 8 do
begin f[i]:=random(10)+10;
write(f[i],' ');
end;
k:=0;
sumb:=0;
for i:= 1 to 8 do
if f[i] mod 2 = 0 then
k:=k+1;
else
sumb:sumb+f[i];
writeln('Количество четных: ',k);
writeln('Сумма нечетных: ',sumb);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота