В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
kolodenkoa444
kolodenkoa444
26.03.2022 14:43 •  Информатика

Написать программу в (pyton), которая для заданного натурального числа n определит, правда ли, что разность между произведением чётных цифр числа и произведение нечётных цифр, взятая по модулю, является простым числом. цифры числа пронумерованы справа налево (начиная от разряда единиц), начиная с 1. использовать максимально эффективный для определения простоты числа.

Показать ответ
Ответ:
vtrutnev
vtrutnev
14.03.2023 13:14
Dpi - количество точек на дюйм
1200dpi - в 1 погонном дюйме 1200 точек (пикселей).
1 дюйм = 2,54 см
Узнаем сколько точек по горизонтали и по вертикали изображения:
21÷2,54=8,26771653543 дюйма ×1200=9921,25984251 пикселей по вертикали
29,7÷2,54=11,6929133858 дюйма ×1200=14031,4960629 пикселей по горизонтали
14031,4960629×9921,25984251=139210118,419 пикселей всего в изображении

N=512 цветов - мощность алфавита. N=2^i
512=2^9 ⇒ 9 битами кодируется 1 пиксель

139210118,419 ×9=1252891065,77 бит - информационный объем  полученного графического файла.

1252891065,77 бит ÷8=156611383,221 Байт ÷1024=152940,803926 Кб ÷1024=149,356 Мб.
0,0(0 оценок)
Ответ:
Hеll
Hеll
23.08.2020 03:08
Const n=10;
var 
  a: array[1..n] of integer;
  p,k: integer;
  i: byte;
begin
  randomize;
  p:=1; k:=0;
  for i:=1 to n do begin
    a[i]:=random(21);
    if (a[i]>0) and (a[i] mod 6 =0) then begin
      p:=p*a[i];
      k:=k+1;
    end;
  end;
  println (a);
  if k>1 then writeln ('Произведение элементов, кратных 6, = ',p)  
    else if k=1 then writeln ('Найден всего 1 элемент, кратный 6, - ',p)
           else writeln ('Нет элементов, кратных 6')
end.

Примеры:

15 7 14 14 1 17 4 2 20 10
Нет элементов, кратных 6

12 11 16 1 20 6 0 8 7 20
Произведение элементов, кратных 6, = 72

14 6 8 3 15 7 14 5 19 15
Найден всего 1 элемент, кратный 6, - 6
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота