В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
rzaynullina
rzaynullina
15.04.2021 00:18 •  Информатика

Написать программу в с++ натуральное число называется совершенным, если оно равно сумме своих делителей, включая 1 и, естественно, исключая это самое число. например, число 6 является совершенным (1+2+3 = 6). найти все совершенные числа, меньшие 100 000.

Показать ответ
Ответ:
mk515
mk515
07.10.2020 03:11
#include <iostream>
using namespace std;

int main(){
    int s;
    for (int i=2; i<=100000; i++){
    s = 1;
    for (int j=2; j<=i/2; j++)
    if (i % j == 0) s+=j;
    if (s == i)
    cout << i << " ";
    }
    return 0;
}

Результат:
6 28 496 8128
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота