В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Maci189
Maci189
08.01.2022 02:34 •  Информатика

, написать программу в Scratch Нужно составить программу, которая выполняет чертеж. 1 клетка = 10 условных пикселей


, написать программу в Scratch Нужно составить программу, которая выполняет чертеж. 1 клетка = 10 ус

Показать ответ
Ответ:
helpppppo
helpppppo
12.04.2022 05:37
// #includes {{{
#include <stdio.h>#include <iostream>#include <cmath>#include <algorithm>#include <fstream>#include <vector>#include <complex>#include <queue>#include <set>#include <map>#include <cstdlib>#include <cstdio>#include <cstring>#include <cassert>#include <ctime>#include <cmath>#include <string>#include <deque>#include <list>#include <math.h>#include <fstream>#include <stack>#include <iomanip>#include <bitset>#include <memory.h>#include <bitset>#include <functional>#include <numeric>#include <utility>#include <sstream>#include <ctime>#include <assert.h>#include <stdarg.h>#include <time.h>#include <limits.h>#include <ctype.h>#include <complex>#include <bits/stdc++.h>// }}} // #defines {{{#define exp 1e-10#define sc scanf#define pr printf#define mk make_pair#define pb push_back#define pf push_front#define ll long long#define fi first#define se second#define eps 0.000000001#define INF 1000000007#define file "management"#define eps 0.000000001#define cmd 1000000009#define PI 3.14159265#define MOD 1000000007#define sz(x) ((int)(x).size())#define in(s) freopen(s, "r", stdin);#define pi 3.1415926535897#define rep(i, n) for(__typeof(n) i = 0; i < (n); i++)#define out(s) freopen(s, "w", stdout);#define sync ios_base::sync_with_stdio( 0 )// }}} using namespace std; typedef long long lglg;const int inf = 1<<30, maxN = 1000;int ax[] = {0, 1, -1, 0, 0};int ay[] = {0, 0, 0, -1, 1}; int main(){    string a;    int n, dp[102][102], i, j, px[102][102], py[102][102];    cin >> a;    memset(dp, 0, sizeof(dp));    memset(px, -1, sizeof(px));    a = "." + a;    n = a.size() - 1;    for (i = 1; i <= n; i++)        dp[i][i] = 1;    for (i = n; i >= 1; i--)        for (j = i + 1; j <= n; j++)        {            if (a[i] == a[j] && dp[i][j] < 2 + dp[i + 1][j - 1])            {                dp[i][j] = 2 + dp[i + 1][j - 1];                px[i][j] = i + 1;                py[i][j] = j - 1;            }            if (dp[i][j] < dp[i + 1][j])            {                dp[i][j] = dp[i + 1][j];                px[i][j] = i + 1;                py[i][j] = j;            }            if (dp[i][j] < dp[i][j - 1])            {                dp[i][j] = dp[i][j - 1];                px[i][j] = i;                py[i][j] = j - 1;            }         }    cout << dp[1][n] <<'\n';    int x = 1, y = n, q, w;    vector<char> ans;    char z = 0;    while (px[x][y] != -1)    {        if (px[x][y] == x + 1 && py[x][y] == y - 1)            ans.push_back(a[x]);        q = px[x][y];        w = py[x][y];        x = q;        y = w;    }    if (x == y)        z = a[x];    for (i = 0; i< ans.size(); i++)        cout << ans[i];    if (z != 0)        cout<< z;    for (i = ans.size() - 1; i >= 0; i--)        cout<< ans[i];    return 0; }   
0,0(0 оценок)
Ответ:
dimandra
dimandra
20.01.2020 01:16

Чтоб был ясен ход мыслей, для начала сделаем это для 10тичной сс

Минимальное 4-значное число (берем что все цифры значимые и нет ведущих нулей) будет 1000 (это первое 4значное число после всех 3значных, т.е. 999+1=1000).

Максимальное 4значное число можно найти отнимая от минимального 5значного единицу 10000-1 = 9999


цифра 1 - это минимальное после 0 и она есть во всех системах счисления.

Потому минимальное 4 значное для всех сс будет 1000

Максимальное будем вычислять так 10000-1



2 сс: 10000-1 = 1111

4 сс: 10000-1 = 3333

6 сс: 10000-1 = 5555

8 сс: 10000-1 = 7777


Надеюсь понятно)

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота