В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Rinana1298
Rinana1298
31.07.2021 09:48 •  Информатика

Написать программу в ! составить процедуру, заменяющую в исходной строке символов все единицы нулями и все нули единицами. замена выполняется, начиная с заданной позиции строки.

Показать ответ
Ответ:
51Qwerty15
51Qwerty15
15.07.2020 20:00
Var
k:integer;
s:string;
procedure Zamena(var ss:string; p:integer);
var
i:integer;
begin
for i:=p to length(ss) do
begin
if ss[i]='1' then ss[i]:='0' else
if ss[i]='0' then ss[i]:='1';
end;
end;
begin
writeln('Введите строку: ');
readln(s);
writeln('Введите позицию с которой начинать замену: ');
readln(k);
Zamena(s,k);
writeln('Измененная строка: ',s);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота