В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Kuzenka2003
Kuzenka2003
03.01.2023 11:34 •  Информатика

Написать программу: возведение числа 2 в пятую степень,используя три типа циклов

Показать ответ
Ответ:
k1122
k1122
07.10.2020 20:46
С++
цикл с после условием do while:
#include <iostream>
using namespace std;
void main()
{
int i=2,p=1,j=0;
do {
p*=i;
j++;
} while (j>5);
cout << p;
cin.get();
cin.get();
}

цикл с перед условием while:

#include <iostream>
using namespace std;
void main()
{
int i=2,p=1,j=0;
while (j>5) {
p*=i;
j++;
}
cout << p;
cin.get();
cin.get();
}

цикл с параметрами for:

#include <iostream>
using namespace std;
void main()
{
int j=2,p=1;
for (int i=0;i>5;i++) p*=j;
cout << p;
cin.get();
cin.get();
}
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота