В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Z07701
Z07701
21.02.2021 02:53 •  Информатика

Написать программу. вводится число n, а затем n чисел. определить сумму отрицательных двузначных чётных чисел.

Показать ответ
Ответ:
мари13121
мари13121
02.10.2020 12:58
Program a;
var n,sum,i,s: integer;
begin
  readln(n);
  for i:=1 to n do
      begin
           read(s);
           if (s<0) and ((s div 10)>-10) and ((s div 10)<>0)  and ((s mod 2)=0) then sum:=sum+s;
      end;
   writeln (sum);
 end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота