В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
славка23
славка23
27.10.2021 13:03 •  Информатика

написать программу вычисления функции y=x 2+a*c при введении x и вывести результаты функции при положительных c .Pascal​

Показать ответ
Ответ:
Hkolnik32
Hkolnik32
17.05.2020 01:58

Значит просто расписать как это должно работать?

Объявляем переменную День, которая будет считывать количество дней.

Вводится H хлеба - общее количество и Z - количество, которое потребляется в день.

Переведем кг в г, чтобы легче было считать: H = H * 1000

Запускается цикл пока H > 0(пока хлеб вообще имеется)

один проход цикла - один день, значит в теле цикла H = H - Z

То есть мы вычитаем из общего кг хлеба суточное потребление.

И увеличиваем переменую День на 1.

После этого цикла выводим переменную День.

Приведу пример на языке с++. В случае ввода H = 1, Z = 50, выводится ответ 20 дней

#include <iostream>

#include <cstdlib>

using namespace std;

int main()

{

int day = 0, Z, N;

cin >> N >> Z;

N = N * 1000;

while(N > 0){

 N = N - Z;

 day++;

}

cout << day << endl;

system("pause");

return 0;

}

0,0(0 оценок)
Ответ:
Kuzenka2003
Kuzenka2003
19.06.2021 09:59

var  

a: array[1..100] of integer;  

n, i: byte;  

sum, p: integer;

begin  

Randomize;  

readln(n);  

sum:=0; p:=1;  

for i:=1 to n do    

begin      

a[i]:=Random(101)-50;      

write(a[i]:4);      

sum:=sum+a[i];      

p:=p*a[i];    

end;  

writeln;  

writeln('Сумма = ', sum:5);  

writeln('Произведение = ', p:5);  

sum:=0; p:=1;  

writeln('');  

writeln('2. С клавиатуры');  

for i:=1 to n do    

begin    

write('Элемент ', i, ' = ');    

readln(a[i]);    

sum:=sum+a[i];    

p:=p*a[i];    

end;  

writeln('Сумма = ', sum:5);  

writeln('Произведение = ', p:5);

end.


Подробнее - на -

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота