В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История

Написать программу вычисления стоимости покупки с учетом скидки 3% сумма больше 200 рублей

Показать ответ
Ответ:
1234567890djsbdnfkd
1234567890djsbdnfkd
02.10.2020 05:48
Для PascalABC:

program Project1;
var i:real;
begin
write('Введите стоимость товара ---> ');
readln(i);
writeln('С учётом скидки товар будет стоить ', i*0,03, ' рублей');
end.

Для Delphi:

var i:real;
begin
write('Vvedite stoimost tovara ---> ');
readln(i);
writeln('S ychetom skidki tovar bydet stoit ', i*0,03, ' ryblei');
readln;
end.

Написал два варианта, так как синтаксис и некоторые моменты немного отличаются с использованием Delphi и PascalABC.
0,0(0 оценок)
Ответ:
lizawera
lizawera
02.10.2020 05:48
Наверное, имелось ввиду, что скидка будет, если сумма более 200 рублей?

var x: integer;
begin
  write('Введите цену: '); read(x);
  if(x > 200) then writeln('Скидка 3%! Стоимость покупки:', (x * 0.97))
  else writeln('Скидки нет! Стоимость покупки: ', x);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота