В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
wardian
wardian
26.03.2023 16:26 •  Информатика

Написать программу вычисления стоимости покупки с учетом скидки. скидка в 10% предоставляется, если сумма покупки больше 1000 руб. ниже рекомендуемый вид экрана во время выполнения программы (данные, введенные пользователем, выделены полужирным шрифтом). вычисление стоимости покупки с учетом скидки введите сумму покупки и нажмите -> 1200 вам предоставляется скидка 10% сумма покупки сучетом скидки: 1080.00 руб.

Показать ответ
Ответ:
zhirovr
zhirovr
31.08.2020 06:45
Var st:real;
begin
writeln('Вычисление стоимости покупки с учетом скидки');
writeln('Введите сумму покупки и нажмите ->');
readln(st);
if st>1000
 then writeln('Вам предоставляется скидка 10%. Сумма покупки с учетом скидки: ',st-st*0.1:5:2,' руб.')
 else writeln('Скидка не предоставляется. Сумма покупки: ',st);
end.

Пример:
Вычисление стоимости покупки с учетом скидки
Введите сумму покупки и нажмите ->
1200
Вам предоставляется скидка 10%. Сумма покупки с учетом скидки: 1080.00 руб.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота