Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
CrySony1
17.02.2023 22:08 •
Информатика
Написать программу вычисления стоимости покупки с учетом скидки. скидка в 5% предоставляется, если сумма покупки больше 2500 руб., в 10% - если сумма больше 3500 руб. в c++
Показать ответ
Ответ:
esmeraldadoctor
08.10.2020 08:34
#include < iostream >
using namespace std;
int main () {
int a;
cout << "Введите сумму покупки: " << endl;
cin >> a;
if (a >= 2500){
cout << "Итог: ";
if (a >= 2500 && a <= 3500)
cout << a*(1 - 0.05) << endl;
else if (a > 3500)
cout << a*(1 - 0.1) << endl;
}
else
cout << "Без скидки. Итог: " << a << endl;
}
0,0
(0 оценок)
Популярные вопросы: Информатика
blablabla114
12.06.2020 02:49
Дано 3 целых числа. определить среди них максимальное четное. написать это на c++...
dmitrijcazovo81
04.02.2021 17:22
2примера разветвляющегося алгоритма...
Вичка11111111
07.11.2021 04:02
В каждой паре чисел массива Z(10) выполнить следующие преобразования: если числа одинаковых знаков, то поменять их местами, а большее из них переписать в массив A; если знаки...
настя7500
25.04.2020 06:04
Вырази в битах. 6 МиБ= ?*?*?*? бит = ? бит...
Eddyp
28.07.2022 20:06
У исполнителя Альфа две команды, которым присвоены номера: 1. прибавь 5; 2. умножь на b (b — неизвестное натуральное число; b ≥ 2). Выполняя первую из них, Альфа увеличивает...
гость162
10.02.2022 06:56
Определить основные функции табличной модели, количество правильных ответов: 2 хранения и обработки графической информации сортировка данных для программного кодаформатирование...
vasyamlodp0c2ay
01.07.2021 08:21
Напишите наименьшее целое число x, для которого истинно высказывание: НЕ (X 9) И НЕ (X нечётное)....
yuliyaduda11
01.12.2022 13:22
заполнить массив из 10 элементов случайными числами в интервале -10 10 и сделать реверс отдельно для 1-ой и 2-ой половин массива на языке C++...
ket851230
30.04.2020 18:12
Выбери фигуры, из которых создана 3D-модельконус цилиндр параллелограмм сфера...
yana3657
19.02.2021 15:15
Господа программисты Мастям игральных карт присвоены порядковые номера: 1 — пики, 2 — трефы, 3 — червы, 4 — бубны Достоинству карт, старших десятки, присвоены номера: 11 — валет,...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
using namespace std;
int main () {
int a;
cout << "Введите сумму покупки: " << endl;
cin >> a;
if (a >= 2500){
cout << "Итог: ";
if (a >= 2500 && a <= 3500)
cout << a*(1 - 0.05) << endl;
else if (a > 3500)
cout << a*(1 - 0.1) << endl;
}
else
cout << "Без скидки. Итог: " << a << endl;
}