В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
almirashagieva
almirashagieva
31.03.2021 12:45 •  Информатика

Написать программу вычисления суммы целых чисел от 1 до n, запрашиваемого с клавиатуры. pascal abc

Показать ответ
Ответ:
Polina19790
Polina19790
21.08.2020 16:25
Var
  i, n: integer;
  sum: longint;
begin
write('n = ');
readln(n);
for i := 1 to n do sum := sum + i;
writeln('Сумма чисел от 1 до ', n , ' = ', sum);
end.
0,0(0 оценок)
Ответ:
Юлиандрv
Юлиандрv
21.08.2020 16:25
Var
  s,n:integer;
begin
  Write('Введите n:');
  Readln(n);
  s:=n+(n*(n-1)) div 2; { сумма арифметической прогрессии }
  Writeln('Сумма чисел от 1 до ',n,' равна ',s)
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота