В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Kaka225
Kaka225
01.11.2021 22:27 •  Информатика

Написать программу вычисления суммы всех 3-х значных чисел, у которых сумма цифр кратно числу а.нахождения суммы цифр 3х значного числа написать подпрограмму. ( с функцией) i = от 100 до 999 i=326 x = i div 100 y=i div 10 mod 10 z= i mod 10 s= x+y+z 2)определить значение переменной после выполнения фрагмента алгоритма: s: =24; m: =3456; while s> 10 do begin m: =m mod 10; s: =s-m end; s: =s+m; write(m); мне нужно именно решение, а не тупо !

Показать ответ
Ответ:
JackBllizard
JackBllizard
21.06.2020 06:27
Function T1(b:integer):integer;
begin
T1:=b mod 10 +(b div 10)mod 10+((b div 10)div 10)mod 10;
end;
Var
i,a,S:integer;
begin
S:=0;
For i:=100 to 999 do
  if T1(i) mod 3 =0
  then S:=S+T1(i);
writeln(S);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота