В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
vikulek1
vikulek1
06.01.2021 06:40 •  Информатика

Написать программу, вычисляющую стоимость покупки с учётом скидки: куплено 4 товара, если сумма превышает 2500р, то скидка составит 5%, если превышает 1300р, то скидка составит 3%​. Нарисовать блок-схему. Язык: Паскаль​

Показать ответ
Ответ:
Fara3747
Fara3747
30.05.2021 14:50

var

summa, skidka: real;

begin

writeln('Вычисление стоимости покупки с учетом скидки.');

writeln('Введите сумму покупки: ');

readln(summa);

 if summa >= 1300 then skidka:=3

  else if summa > 2500 then skidka:=5

   else if summa < 1300 then skidka:=0;

writeln('Вам предоставлена скидка ', skidka, '%');

writeln('Сумма покупки с учетом скидки: ', (summa-(summa*skidka)/100));

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота