В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
23LOLKEK
23LOLKEK
30.12.2022 11:52 •  Информатика

написать программу, вычисляющую сумму бесконечного ряда с заданной точностью. в Pascal. Если можно, то с минимальными объяснениями.


написать программу, вычисляющую сумму бесконечного ряда с заданной точностью. в Pascal. Если можно,

Показать ответ
Ответ:
pminikrolik
pminikrolik
29.04.2021 22:43

function factorial(x:real): real;

begin

   if x = 1 then factorial := 1

   else factorial := x * factorial(x-1);

end;

function F(n:integer; x:integer): real;

begin

   if n = 1 then F:=3*sqr(x)/2

   else F:=exp(n*ln(3))*exp(2*n*ln(x))/factorial(2*n) + F(n-1, x);

end;

var n,x:integer;

begin

   x := 2;

   n := 50;

   write(F(n,x):0:2);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота