В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Arse12345
Arse12345
08.11.2020 02:03 •  Информатика

Написать программу вывода на экран всех трехзначных чисел, кратных и 6, и 4, и заканчивающихся на цифру 8. программу написать темя с использованием циклов for, while, repeat. !

Показать ответ
Ответ:
artemkatopchik
artemkatopchik
08.06.2020 15:05

 Var i:integer;

begin

for i:=100 to 999 do if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');

end.

 

{While}

Var i:integer;

begin

 i:=100;

while i<=999 do begin

if( if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' '); inc(i); end;

end.

 

 

 {Repeat}

Var i:integer;

 begin

i:=100; 

repeat

begin

 if(i mod 6 =0) and (i mod 4 = 0) and (i mod 10 = 8) then write(i, ' ');

inc(i); end; 

until i<1000;

end.

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота