Написать программу, выводящую на синем фоне желтыми буквами следующий текст, который надо расположить на экране с 10-й позиции, 14-й строки: Что в мой жестокий век восславил я свободу И милость к падшим призывал. (А.С. Пушкин)
2. Опечатка, вероятно. Либо наибольшее X - тогда 99, либо наименьшее натуральное x, и тогда это будет 1, либо НЕ меньше 100, тогда 101
3. Немного запутано, но по идее: число должно быть четным и меньше 10. Максимальное такое число: 8
4. X больше либо равен 7, или x меньше 6. Единственное число, которое НЕ подходит под эту формулу: 6
10. Обычное уравнение вида При том что n только натурален. Очевидно, что n = 2
17. Надо просмотреть каждую пару чисел и поставить плюсик, если первое больше 15 или второе больше 9. Я загнул пять пальцев, лучше меня перепроверить
25. У эсминца всего 2500 из которых 500 принадлежат также и фрегату. А всего-всего их 4500. Значит ТОЛЬКО эсминцу принадлежат 2000, ТОЛЬКО фрегату тоже 2000, а фрегату всего 2000+500 = 2500. Я понимаю, что ничего из этой писанины понять невозможно, так что прилагаю картиночку, написанную замороженной куриной лапой.
45. Столько писанины, а проще взять листочек в клеточку и самому побыть роботом, исполняя команды. Если у меня все верно, то за один цикл получается общее смещение на 1 вверх и 1 вправо. Значит за 5 циклов будет смещение (5,5) и чтоб переместиться в начало надо дать команду (-5,-5)
53. Третья строчка аналогична: a = 2*4 + 7*3. Любой второклассник скажет, что это 29. Четвертая строчка аналогична: b = 30-29 = 1. Таким образом, у нас a = 29, b = 1. А просят найти именно b. В ответ пишем 1
var a: array[1..100, 1..100] of real; max, min: real; sum, product: real; i, j, m, n, k: integer;
begin {ввод матрицы} if handsfree then begin n := random(20) + 2; m := random(20) + 2; end else begin write('n, m ='); readln(n, m); end;
writeln('Данные матрицы:'); for i := 1 to m do begin for j := 1 to n do if handsfree then begin a[i, j] := random(100) - 50; write(a[i, j]:4, ' ') end else read(a[i, j]); writeln; end;
{минимумы и максимумы} max := a[1, 1]; min := a[1, 1]; for i := 1 to m do for j := 1 to n do begin if max < a[i, j] then max := a[i, j]; if min > a[i, j] then min := a[i, j]; end; writeln('max = ', max); writeln('min = ', min);
{сумма, произведение, пр. агригаты} sum := 0; product := 1; for i := 1 to m do for j := 1 to n do if a[i, j] <> 0 then {если нужен фильтр} begin sum := sum + a[i, j]; product := product * a[i, j]; k := k + 1; end; writeln('sum = ', sum); writeln('product = ', product); writeln('average = ', sum / (n * m)); writeln('average (selected) = ', sum / k); end.
1. Число не меньше 50 и четное: 50
2. Опечатка, вероятно. Либо наибольшее X - тогда 99, либо наименьшее натуральное x, и тогда это будет 1, либо НЕ меньше 100, тогда 101
3. Немного запутано, но по идее: число должно быть четным и меньше 10. Максимальное такое число: 8
4. X больше либо равен 7, или x меньше 6. Единственное число, которое НЕ подходит под эту формулу: 6
10. Обычное уравнение вида При том что n только натурален. Очевидно, что n = 2
17. Надо просмотреть каждую пару чисел и поставить плюсик, если первое больше 15 или второе больше 9. Я загнул пять пальцев, лучше меня перепроверить
25. У эсминца всего 2500 из которых 500 принадлежат также и фрегату. А всего-всего их 4500. Значит ТОЛЬКО эсминцу принадлежат 2000, ТОЛЬКО фрегату тоже 2000, а фрегату всего 2000+500 = 2500. Я понимаю, что ничего из этой писанины понять невозможно, так что прилагаю картиночку, написанную замороженной куриной лапой.
45. Столько писанины, а проще взять листочек в клеточку и самому побыть роботом, исполняя команды. Если у меня все верно, то за один цикл получается общее смещение на 1 вверх и 1 вправо. Значит за 5 циклов будет смещение (5,5) и чтоб переместиться в начало надо дать команду (-5,-5)
53. Третья строчка аналогична: a = 2*4 + 7*3. Любой второклассник скажет, что это 29. Четвертая строчка аналогична: b = 30-29 = 1. Таким образом, у нас a = 29, b = 1. А просят найти именно b. В ответ пишем 1
const
handsfree = true;
var
a: array[1..100, 1..100] of real;
max, min: real;
sum, product: real;
i, j, m, n, k: integer;
begin
{ввод матрицы}
if handsfree then begin
n := random(20) + 2;
m := random(20) + 2;
end
else begin
write('n, m =');
readln(n, m);
end;
writeln('Данные матрицы:');
for i := 1 to m do
begin
for j := 1 to n do
if handsfree then begin
a[i, j] := random(100) - 50;
write(a[i, j]:4, ' ')
end
else
read(a[i, j]);
writeln;
end;
{минимумы и максимумы}
max := a[1, 1];
min := a[1, 1];
for i := 1 to m do
for j := 1 to n do
begin
if max < a[i, j] then max := a[i, j];
if min > a[i, j] then min := a[i, j];
end;
writeln('max = ', max);
writeln('min = ', min);
{сумма, произведение, пр. агригаты}
sum := 0;
product := 1;
for i := 1 to m do
for j := 1 to n do
if a[i, j] <> 0 then {если нужен фильтр}
begin
sum := sum + a[i, j];
product := product * a[i, j];
k := k + 1;
end;
writeln('sum = ', sum);
writeln('product = ', product);
writeln('average = ', sum / (n * m));
writeln('average (selected) = ', sum / k);
end.