В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
DanilVolkov95
DanilVolkov95
01.12.2022 22:27 •  Информатика

Написать программу, выводящую сумму номеров строк, в которых последний код первой строки встречается в них столько-же раз, сколько он встречается в первой строке. Пример:
5 26.11.2018
789 ugf ft4 tyu ft4 7876 ft4
iuh ft4,iyv 7876 ytf ytf
765f ft4,jhf 5676 ft4,jhg ft4,ju
ytrdytrty999
gy ft4 765 ft4 hgft4 u76 ft4 drt

Показать ответ
Ответ:
armanovi05
armanovi05
10.05.2021 15:06
Тут легко, нарисовать правдо не могу сейчас, первым делом это блок начало, затем блок ввода числа б , то есть количество машин, затем следующий блок ввода данных а, то есть цена машины, затем блок рассчета, с=а*б, то есть подсчёта выручки, затем блок вывода выручки и блок конец. Могу программу попробовать накидать если напишешь язык программирования

По логике так, возможны ошибки

Алг задача
Нач
Цел a, b,c
Вывод "введите количество проданных машин: "
Ввод а
Вывод "введите цену за автомобиль: "
Ввод b
С:=а*b
Вывод c
Кон
0,0(0 оценок)
Ответ:
vladrydskoj
vladrydskoj
04.05.2022 12:59
1)

const
  n=40;
var
  a:array [1..n] of integer;
  i,k:integer;
begin
  Randomize;
  k:=0;
  Writeln('Исходный массив');
  for i:=1 to n do begin a[i]:=random(63)+20; Write(a[i],' ') end;
  Writeln; Writeln('Четные элементы, кратные 3');
  for i:=1 to n do
    if a[i] mod 6=0 then begin Inc(k); Write(a[i],' ') end;
  Writeln; Writeln('Отобрано элементов: ',k)
end.

Пример
Исходный массив
43 49 27 45 57 20 54 22 74 79 57 64 30 41 67 58 36 68 79 46 28 74 61 21 80 57 50 24 80 36 27 57 38 38 41 71 50 69 39 48
Четные элементы, кратные 3
54 30 36 24 36 48
Отобрано элементов: 6

2)

const
  n=20;
var
  a:array [1..n] of integer;
  i,imin:integer;
begin
  Randomize;
  Writeln('Исходный массив');
  imin:=1;
  for i:=1 to n do begin
    a[i]:=random(351)+20;
    Write(a[i],' ');
    if a[i]<a[imin] then imin:=i
    end;
  Writeln;
  Writeln('Минимальный элемент a[',imin,']=',a[imin])
end.

Пример
Исходный массив
292 54 248 310 181 210 263 284 255 156 177 340 173 39 108 144 270 40 318 155
Минимальный элемент a[14]=39
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота