В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Anatoliy1111111
Anatoliy1111111
17.03.2021 11:16 •  Информатика

Написать программу! ! while и repeat 1)напечатать все отрицательные числа из диапазона от а до б, с шагом h. 2)напишите программу, при выполнении которой с клавиатуры считывается натуральное число n, не превосходящее 10^9, и выводится сумма четных цифр этого числа и 0, если таких цифр в числе нет

Показать ответ
Ответ:
Milanusia
Milanusia
01.10.2020 16:56
1.program z;
var a,b,c:integer;
begin
read(a,b,c);
while (a<b) and (a<0) do
begin
write(a:4);
a:=a+c;
end;
end.
2.program z;
var a,b,c:integer;
begin
read(a,b,c);
repeat
write(a:4);
a:=a+c;
until (a>b) or (a>-1);
end.
0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота