Войти
Регистрация
Спроси ai-bota
В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Показать больше
Показать меньше
mstuckov98
05.07.2020 19:55 •
Информатика
Написать программу, запрашивающая 3 целых числа и выводящая сумму этих чисел, если максимум этих чисел больше 12.
Показать ответ
Ответ:
Uchenicza
03.10.2020 12:29
//Нам не обязательно находить максимум чтобы выполнить условие
//Pascal ABC.NET v3.1 сборка 1172
//Продвинутый уровень
begin
var seq:=ReadArrInteger(3);
if seq.any(x -> x>12)=true then writeln(seq.Sum) else writeln('Нет')
end.
//"Школьный" уровень
Var
a,b,c:integer;
begin
read(a,b,c);
if (a>12) or (b>12) or (c>12) then writeln(a+b+c) else writeln('Нет');
end.
Пример ввода:
1
1
13
Пример вывода:
15
0,0
(0 оценок)
Популярные вопросы: Информатика
Bbbbkoo
20.03.2023 08:26
В ProTeam есть много сотрудников, которые работают даже в выходные. За дополнительную работу они должны награждаться премиями. Напиши программу для расчёта премий, которая будет:...
Петя1134
12.04.2021 17:38
Приведите 3 примера носителей информации из литературных произведений.Почему вы их выбрали?...
карина2153
11.08.2022 05:17
Переведите две формулы на язык С++....
DarckGh0st
30.05.2023 18:07
Дан порядковый номер дня года(отсчёт идёт с 1 января). Требуется вывести номер дня недели этого дня,если 1 января-понедельник.(Запрещено использовать if и while) на Python...
zuza81ozzhmr
15.01.2022 23:32
Дана сторона квадрата а. найти его периметр р=4*а...
vika0820
20.11.2020 01:15
Цифровые носители информации урок 2 введи с клавиатуры ответ...
AlecL
25.11.2021 12:03
Здрасте. Можете подсказать, где можно найти функцию МОДА.НСК для Microsoft Excel 2007 года? Не могу найти ни в програме, ни какой-нибудь файл в интернете....
NoNameRu1
15.02.2021 02:42
2 упр это очень легко но я не понимаю...
Den4ikBLeT
06.10.2020 21:17
Решите проблему на языке. паскаль...
evgehamorozov
17.11.2022 07:58
Мальчик Вася делает домашнее задание за t минут. Написать программу на Pascal для определения: сколько бы ему понадобилось школьных уроков без перемен, чтобы выполнить это задание...
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку
О НАС
О нас
Блог
Карьера
Условия пользования
Авторское право
Политика конфиденциальности
Политика использования файлов cookie
Предпочтения cookie-файлов
СООБЩЕСТВО
Сообщество
Для школ
Родителям
Кодекс чести
Правила сообщества
Insights
Стань помощником
ПОМОЩЬ
Зарегистрируйся
Центр помощи
Центр безопасности
Договор о конфиденциальности полученной информации
App
Начни делиться знаниями
Вход
Регистрация
Что ты хочешь узнать?
Спроси ai-бота
//Pascal ABC.NET v3.1 сборка 1172
//Продвинутый уровень
begin
var seq:=ReadArrInteger(3);
if seq.any(x -> x>12)=true then writeln(seq.Sum) else writeln('Нет')
end.
//"Школьный" уровень
Var
a,b,c:integer;
begin
read(a,b,c);
if (a>12) or (b>12) or (c>12) then writeln(a+b+c) else writeln('Нет');
end.
Пример ввода:
1
1
13
Пример вывода:
15