В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
emalets20042
emalets20042
01.08.2021 06:20 •  Информатика

Написать программу, запрашивающую пять чисел и суммирующию только положительные из них. значение суммы вывести на экран.

Показать ответ
Ответ:
Даниюша3223
Даниюша3223
09.10.2020 04:34

uses crt;

const n=5;

var a:array[1..n] of integer;

   s,i:integer;

begin

    for i:=1 to n do

    read(a[i]);

    for i:=1 to n do

    write(a[i]:3);

    for i:=1 to n do

    begin

         if (a[i]>0)and(a[i]<>0) then s:=s+a[i];

    end;

    writeln;

    write(s);

end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота