В
Все
М
Математика
О
ОБЖ
У
Українська мова
Д
Другие предметы
Х
Химия
М
Музыка
Н
Немецкий язык
Б
Беларуская мова
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
Р
Русский язык
У
Українська література
Ф
Французский язык
П
Психология
А
Алгебра
О
Обществознание
М
МХК
В
Видео-ответы
Г
География
П
Право
Г
Геометрия
А
Английский язык
И
Информатика
Қ
Қазақ тiлi
Л
Литература
И
История
Turbik327
Turbik327
17.07.2020 05:17 •  Информатика

Написать программу, запрашивающую с клавиатуры целые числа и определяю-щую максимальное и минимальное из них. окончание ввода – число 0. протестиро-вать программу для последовательности: -3 5 6 -11 24 -1 0. паскаль

Показать ответ
Ответ:
sanya1130
sanya1130
15.06.2020 23:46


uses crt;
var x,min,max:integer;
begin
clrscr; min:=0;max:=0;
Writeln('Write x = ');
readln(x);
min:=x;
max:=x;
while x<>0 do
begin
readln(x);
if ((min > x) and (x<>0)) then min:=x;
if ((max < x) and (x<>0)) then max:=x;
end;
writeln('max = ',max);
writeln('min = ',min);
readln
end.

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота