В
Все
М
Математика
О
ОБЖ
У
Українська мова
Х
Химия
Д
Другие предметы
Н
Немецкий язык
Б
Беларуская мова
М
Музыка
Э
Экономика
Ф
Физика
Б
Биология
О
Окружающий мир
У
Українська література
Р
Русский язык
Ф
Французский язык
П
Психология
О
Обществознание
А
Алгебра
М
МХК
Г
География
И
Информатика
П
Право
А
Английский язык
Г
Геометрия
Қ
Қазақ тiлi
Л
Литература
И
История
Dan1yar2255
Dan1yar2255
13.08.2021 09:57 •  Информатика

Написать программу (желательно на питоне) или на любом языке про температуру
: известны дневные и ночные температуры мая. определить дни, когда перепад
температур был максимальным.

Показать ответ
Ответ:
qwerty1127
qwerty1127
10.10.2020 06:56

Написано на Pascal

var

 Night:array [1..31] of integer ; //Массив с ночными температурами

 Day:array[1..31] of integer; //Массив с дневными температурами

 i,dif: integer;

begin

 dif:=0; // Разница

 for i:=1 to 31 do // Цикл заполняющий дневные и ночные температуры(Тут без отрицательных температур)

 begin  

   Night[i]:=random(30); // Рандомная ночная температура

   Day[i]:=random(30); // Рандомная дневная температура

 end;

 for i:=1 to 31 do // Цикл, который ищет максимальную разницу

   if (Day[i]-Night[i])>=dif then

   begin  

     dif:=Day[i]-Night[i];

   end;

 for i:=1 to 31 do // Цикл, который выводит дни с максимальной разницей

 if dif=(Day[i]-Night[i]) then

 writeln('Разница '+dif+'; '+i+' Мая');

end.

Объяснение:

0,0(0 оценок)
Популярные вопросы: Информатика
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота